Author Topic: Zabbix Appliance 3.2.6 inconsistencies  (Read 891 times)

Offline Edd Noman

  • Administrator
  • Newbie
  • *****
  • Posts: 33
  • Karma: +2/-0
    • View Profile
Zabbix Appliance 3.2.6 inconsistencies
« on: June 08, 2017, 10:09:30 AM »
Hello everyone, I just did a fresh lab deployment of the Zabbix Appliance 3.2.6 and I noticed some inconsistencies from my old lab deployment of Zabbix Appliance 3.0.4

Both ISO files where download from: https://sourceforge.net/projects/zabbix/

Hostname on 3.0.4 is set to: zabbix
Hostname on 3.2.6 is set to: ubuntu

This should be set to zabbix or zabbix-appliance on all versions or a even better option would be a prompt during install to set the hostname, also if you would use Static IP or DHCP configuration, this is a enterprise level server appliance to be deployed in lots of different network environments after all.

Another issue is whit the scrip: Detect operating system,
Command: sudo /usr/bin/nmap -O {HOST.CONN} 2>&1

Does not work as it is not added into sudoers list and nmap is not not installed so after editing it to allow to run the sudo command, it gives error command not find as nmap is not installed to begin whit, this should have been in there to begin whit or this option should have been removed from the front end

This issue is on both version, lucely these are minor issues that are easy to fix, just add the zabbix usergroup to sudo users whit visudo, and then install nmap on the device


Running Script on a detected host, no changes made


Editing sudo users to allow zabbix users to run sudo commands


Running OS Detection script against detected host after sudo rights


Running OS Detection script after nmap was installed